Joining Bits Shop

How To Recover PrismCube Ruby after a failed flash

Discussion in 'PrismCube Ruby General HowTo & Guides' started by angelofsky1980, Oct 26, 2013.

  1. angelofsky1980

    angelofsky1980 Black Hole Drivers Specialist

    Messages:
    84
    With this how to you can recover your PrismCube Ruby box if the flash process of an Image is corrupted and the fan is on and the led is red.

    Latest emergency-update image is dated 2014-03-05

    First of all, you should get ready the items you will need to make a recovery:
    - a jumper like the one in the the following photo
    IMG_0844.JPG
    - a null modem cable (9 PIN) to connect your PC and PrismCube Ruby and a USB-to-serial converter if your PC doesn't have a serial port
    - terminal software: Tera Term (attached in this thread)
    - necessary loaders and files (attached in this thread)

    Preliminary Step: get all the necessary software and files:
    - download Tera Term from this thread and install it on Windows PC: you should unzip it and it's ready to be used :)
    - download UART Loader (uldr.bin.zip) and unzip it into a temporary folder
    - download U-Boot (u-boot.zip) and unzip it into a temporary folder
    - download LATEST Emergency Update from this thread and unzip into a temporary folder

    First step: open the box
    - Disconnect the power supply from the box
    - Open the box with care and remove the cover. You should see the mainboard
    IMG_0842.JPG
    - locate the jumper JP9 (UART_BOOT) and insert the jumper on the pins. Here is the photo of the mainboard with the JP9 located into a green circle (thanks to Paolino for the photo):
    ponticello.JPG

    - connect your null modem cable between the box and the PC

    Second step: use Tera Term
    - open Tera Term and you will see the "Tera Term New connection" panel:
    1_start_tera_term.png

    - Put "Serial" and select the COM port you are used to connect the null modem cable and press OK
    - The Tera Term main program window appears:
    2_tera_term_main_window.png

    - now it's time to setup serial port speed: click on Setup -> Serial Port and the corresponding setup panel appear:
    3_serial_port_speed_setup.png
    Select into "Baud Rate" the value 115200 and confirm with OK.

    - Download from this thread the official Emergency Update image, unzip it and place the "update_ruby" folder into a USB pendrive FAT32 formatted
    - Connect the USB stick on your box
    - Connect the power cable to your box: you will see something appear on the Tera Term window:
    4_tera_term_with_box_in_upload_mode.png
    You can see the "C" letters continue to be printed on the console screen: it's a very good sign, and means that the box is waiting for something.

    - Now select File -> Transfer -> YMODEM -> Send and select uldr.bin.uartboot_img extracted from uldr.bin.zip
    This will transfer the file to your box ...
    5_uldr_transfer.png

    - Now there is more info on the console screen:
    6_teraterm_screen_after_uldr.png
    Now the box it's waiting for U-Boot file to proceed.

    - AGAIN select File -> Transfer -> YMODEM -> Send and select u-boot.bin extracted from u-boot.zip
    This will transfer the file to your box ...
    6_uboot_transfer.png

    - after uploading U-Boot, the console screen changes and the box will start to AUTOMATICALLY flash the Emergency Image:
    7_console_boot_emergency.png
    TAKE CARE ON THE LINE "scanning bus for storage devices..." because not all USB disks are recognised as valid and in this line it will be reported how many USB stick are detected and automatically used. If you see something different than "1 Storage Device(s) found" you MUST repeat all the steps above with another USB stick.

    The box now continues it's internal operations as if you had flashed it the usual way with the Emergency Update.
    At the end of this step, the display shows the usual "Remove USB".

    Now power off the box and remove the jumper on JP9.

    Now you can power on your box as usual :) and refit the cover, after you have checked that the box is working correctly.

    angelofsky1980 with help from BigEd :)
    Black Hole Team
    Thanks also to Old_ member for useful info about PNX84xx CPUs and aymen lahbib for uldr.bin and u-boot files

    Attached Files:

    Last edited: Oct 20, 2014
  2. levi

    levi Moderator

    Messages:
    337
    Thank you this is very useful :)


    Sent from my iPhone using Tapatalk - now Free
    Last edited: Oct 26, 2013
    AlexM and angelofsky1980 like this.
  3. Dzoni

    Dzoni Moderator

    Messages:
    76
    Great !
    Very useful !
  4. Ev0

    Ev0 Administrator

    Messages:
    175
    Excellent guide, very helpful and well explained :)
    aymen lahbib likes this.
  5. aymen lahbib

    aymen lahbib PrismCube User

    Messages:
    119
    thank u all.
    but it did not work with me.
    i really followed step by step.
    anyway happy for efforts everybody made
  6. Old_

    Old_ PrismCube Newbie

    Messages:
    6
    Congratulation for the explanation and the test with the Prismcube.:)
    angelofsky1980 likes this.
  7. BigEd

    BigEd Moderator

    Messages:
    64
    strange. Write step by step what you have done
    aymen lahbib and angelofsky1980 like this.
  8. >>Artorius<<

    >>Artorius<< Administrator

    Messages:
    15
    Great post Ale ;)
    angelofsky1980 likes this.
  9. seccoleo

    seccoleo Moderator

    Messages:
    35
    very well
    Great job angel
    Also this time the dear Big has found a way to
    to discover a solution that was missing.
  10. aymen lahbib

    aymen lahbib PrismCube User

    Messages:
    119
    it could be my old computet.or firewall.or serial port.or......cable.or priscube itself.
    i send it back to reseller.he engaged a replacement procedure
  11. levi

    levi Moderator

    Messages:
    337
    Hope you get quickly your replacement


    Sent from my iPhone using Tapatalk - now Free
  12. aymen lahbib

    aymen lahbib PrismCube User

    Messages:
    119
    Ok thanks levi.

    Envoyé de mon GT-I9100 en utilisant Tapatalk
  13. aymen lahbib

    aymen lahbib PrismCube User

    Messages:
    119
    may be should i retry with another computer
  14. paolino

    paolino Moderator

    Messages:
    582
    Be sure about your COM port. In most cases USB2serial adapters are the problem.
    aymen lahbib likes this.
  15. aymen lahbib

    aymen lahbib PrismCube User

    Messages:
    119
    I flashed a dm500s .it worked....
    It should wofk with prismcube or it is different from dm?

    Envoyé de mon GT-I9100 en utilisant Tapatalk
  16. paolino

    paolino Moderator

    Messages:
    582
    Should work without any problem. Except HW problems.
  17. aymen lahbib

    aymen lahbib PrismCube User

    Messages:
    119
    That s my case i think it is over for my prism.hopefully guaranty is there

    Envoyé de mon GT-I9100 en utilisant Tapatalk
  18. faroukn91

    faroukn91 PrismCube User

    Messages:
    110
    IP address in the program TeraTerm know how
  19. paolino

    paolino Moderator

    Messages:
    582
    Tera Term is working in Serial Mode, so IP isn't necessary.
  20. angelofsky1980

    angelofsky1980 Black Hole Drivers Specialist

    Messages:
    84
    As said by Paolino, following my tutorial it's not required an IP address.
    Read carefully steps proposed with photos.

Share This Page